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Page Layouts in ArcGIS Pro

What’s new in Pro

The biggest change from ArcMap is that layouts are no longer tied to a single map document.
Because of the new project structure in Pro, a single map view can be used in many layouts.

This should greatly increase efficiency in map categories such as Operations, which often
includes multiple maps of the same content in different areas and scales.

Currently this requires an mxd for each map with its own data links, settings, and layout. Adding
or removing content and symbology changes must be done in each mxd separately.

Pro allows a single map view to be created and then inserted in multiple layouts. This will allow
a single map to define the symbology and content for all the layouts it is added to.

All the essential layout elements have carried over from ArcMap, but a few have new names
(eg Data Driven Pages is now Map Series). For full documentation on Pro Layouts, see the _

|Esri Help pages. |

Layouts Included in the Pro Project Template

The included 2019 _ProProjectTemplate.aprx in the projectsfolder is already configured with a
map view and layouts for the most common page sizes.

All the text elements in these layouts are dynamic. The project specific items (Title, Date and
Operational Period, Author) are sourced from map view metadata while incident specific items
(Incident Name, Incident ID, Current Acreage) are sourced from the DynamicTextUpdate table

in the _other _incident data.gdb. This should further reduce time spent updating daily products.

For more information on the initial configuration of the Pro Project Template, see the How-To
document!Prepare and Configure the Event GDB with ArcGIS Pro.
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http://pro.arcgis.com/en/pro-app/help/layouts/layouts-in-arcgis-pro.htm
https://www.nwcg.gov/sites/default/files/publications/936-1-prepare-and-configure-event-gdb-with-arcgis-pro.pdf

04/08/2019

Creating a New Incident Product

1. Open the Pro Project Template and immediately use Save As to create a new APRX in

the projects folder (name per GSTOP standards).

(™) |[E] » Computer » 0S(C) » 2019 Incidents » 2019_ProDemoFire »

Organize ¥ New ltem ¥
- Project Name

I Folders B 2019_ProProjectTemplate
4 [0 computer B backups

B Desktop B Index

projects »

B Documents edit_2019_ProDemoFire_ABC123_PeterParker.aprx

B Downloads
m 0s(C)

Name}| iap_2019_ProDemoFire_ABC123.aprx || Projects (APRX) i

Save Cancel

2. Open the {MapType} 2019 {IncidentName} map view and rename it to the map type

and incident.

Drawing Order
‘ D iap_2019_ProDemoFire‘
4 |/| 2019 Event Group Layer Point Labels Defined
) Event Point
) Event Line
P« | Event Polygon

4 Standalone Tables

EE] DynamicTextUpdate
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3. Click the red exclamation mark on one of the Event features to repair the data source to
the Master Incident GDB.

Catalog D iap_2019_ProDemoFire X

Drawing Order
4 D iap_2019_ProDemoFire
4 || 2019 Event Group Layer Point Labels Defined
Pl v Event Point

| Event Line

® )@ [El« 2019 _ProDemoFire ABC123_Event ArcPro_23.gdb

Pl¥| & Event Polygon
4 Standalone Tables Organize ¥ New ltem ~

D DynamicTextUpdate 4 Project Name

B Databases AccountableProperty
I Folders EventPoint
Portal IRPoITT
My Content LabelPoint
3 Groups (&) StructureTriage
All Portal
Living Atlas

Name | EventPoint Point and Multipoint Feature Class ~

4. Update the source for the DynamicTextUpdate table to the incident’s
_other_incident_data.gdb, if necessary. Some dynamic text will not display if this link is
broken.

Catalog D {MapType} 2019 _{IncidentName} X

Drawing Order
4 D {MapType}_2019_{IncidentName}
4 |¢/| 2019 Event Group Layer Point Labels Defined

) Event Point
) Event Line

;\ ) « o i inci M| | Sear voject
p[] 1 Event Polygon £ T D 2019_ProDemoFire_ABC123_other_incident_data.gdb | ¥ |(O)| | Search Projec

4 Standalone Tables Organize ¥ New ltem ¥

E=| ! DynamicTextUpdate 4 Project Name
& Databases [ES) DynamicTextUpdate k‘
M Folders
Portal

My Content

, Groups

All Portal
Living Atlas

Name | DynamicTextUpdate Tables (All Types)

o | [ |
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5. If the Acres and Acres Effective Date are incorrect, this and any other projects should be
closed and the DynamicTextUpdate table should be edited from the Edit Project.

6. Add the appropriate base map(s) and any ancillary data necessary for the product.

7. From the Contents pane in the Catalog view, open the project Layouts. Select the
appropriate size and orientation for the product.

Contents , Catalog X [IZ] iap_2019_ProDemoFire

Braject D » Project » Layouts

F[EI Maps Name Type
= Toolboxes [E) Layout 11x17 Land Layout
Layout_11x17_Port Layout

[& Databases =

@ Layouts Layout 18x24(ArchC) Land Layout

= Styles = Layout 18x24(ArchC) Port Layout

N Folders =

p!‘j locators = Layout 24x36(ArchD) Port Layout
Dortal =4 Layout 36x48(ArchE) Land Layout
My Content = Layout 36x48(ArchE) Port Layout

3 Groups =4 Layout 85x11 Land Layout

]
|
]
|
| Layout 24x36(ArchD) Land Layout
|
]
|
]
|

All Portal E Layout 85x11_Port Layout

Living Atlas

8. Activate the map frame from the Layout ribbon and zoom or pan to the area of interest.
This can be done a number of ways including Manually, Zoom to Layer, a Bookmark,
and Zoom/Pan to feature. Double-check the scale is correct for the product.

Project Insert Analysis View Imagery Share Appearance Labeling Data

‘E> ‘_j —2; : Select All DL [G ] V| Rulers
v It T

ABC

= V| Guides| e o lj,‘
Navigate 8 Qrientation Map Activate Bookmarks  Check

Series~ Spelling

S

Catalog D iap_2019_ProDemoFire E;] Layout_11x17_Land X

Search 0 r—:‘|
Close the Activation when the map displays the desired area at the appropriate scale.

Close
Activation
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9. From the Catalog view, right-click the map view and select Edit Metadata.

Catalog X I:I iap_2019 ProDemofFire [;‘_] Layout 1

® 'f‘ [ » Project » Maps »

Name

D iap_2019_ProDemokFire [:l
Open

E“W Convert

Efl copy
Export To File...

Rename

Delete

Edit Metadata k

10. Enter the Title under Summary.
Enter the Date and Operational Period under Description.
Enter the Author name or initials under Credits.
Click Apply to save the changes.

o

Project

The Layout may need to be refreshed for the text to update.

122°3|6.Q1'WI i ‘ I122°3|5.5"W‘ e n s n 1 122°3?.Q1'WI 5 ‘ I122°3|5.5"W‘ - - 1
1 Enter Title Here { IAP Map
ProDemo Fire | ProDemo Fire
= ABC123 —? ABC123
71  Date and OP of Use =1 April 10, 2019 Day Shift
- 545 Acres at 4/9/19 0223 545 Acres at 4/9/19 0223

11. Make any final adjustments to layout elements.
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Create Different Size or Area of the same Product
Once a product has been created at one size, to recreate it with different dimensions simply

open the desired layout and activate the map frame to set the area and scale.

To create the same product in multiple areas, simply make a copy of the desired layout and
activate the map frame to set the desired area and scale.

All the map element (symbology, annotation, basemaps, etc) will be the same because they are
all tied to the same map view.

All the text elements will be identical and prepopulate because they are all tied to the same
dynamic settings.

Elements highlighted in Yellow below are sourced from the Map View Metadata.

Elements highlighted in Green below are sourced from the DynamicTextUpdate table.

The date/time and datum are sourced from the system.

Enter Title Here
Incident Name

Unit and Fire ID
Date and OP of Use

43°50'N

43°49.5'N

Enter Author Name Here
4/19/2019 1129

Acres from IR and GPS
WGS 1984 Datum. LatLong Grid

43°40.5'N

121°14.5'W 121°14'W
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Create a New Layout

Creating a new layout is as simple as clicking the New Layout button on the Insert tab of the
ribbon and selecting the page size.

53

Project Catalog Analysis View Imagery Share

'Q‘ '3:1' W] j ¥ Import Map 5 Add Folder €% Add ~ +.
¥ Connections ~ Task ~ @ New ~
New New New :I ' Add

Map 1 Layout~ Report~ = Toolbox ~ 2 Import  jtem ~

ANSI - Portrait

Letter Tabloid
8.5" x 11 50 % 14" 117 % 17

ANSI - Landscape

The layout should be renamed following GSTOP standards from the Catalog pane, under
Layouts.
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In the new layout, the map view can be added from the Map Frame dropdown on the Insert tab
of the ribbon. The Insert tab is also where most the standard map elements (north arrow, scale
bar, legend, etc) can be found as well.

Analysis View Imagery Share

i& Import Map 5 Add Folder {:}_| Rectangle ~ T o510
E™

¥3 connections - :] Task ~

A Map North Scale Legend Char
¢ Toolbox ~ Frame~ Arrow > Bar~ Frame

7 x Cai {MapType} 2019 {IncidentName}

L [ —
Bl
N

Default Extent 1:5,820,289

Other

By clicking the Activate button on the Layout tab of the ribbon, the placement and scale of the
map can be set within the layout.

Project Insert Analysis View Imagery Share Appearance Labeling Data

1&; K_j % ol 7 Select All r X Hj_,' = 2 Vi | —y lj ‘ =
! i V| Guides| | SS== £ -l
Navigate Select Crientation Map Activate Bookmarks  Check

=
Series~ Spelling

S

These settings will not be affected by panning or zooming in the Map View. However, any edits,
selections, layer visibility, symbology changes, etc will be visible in all layouts which contain the
Map Frame.
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Save as a Layout File

Layouts can be shared as .pagx files, aka a layout file. This will include the all the layout
elements as well as any map frames on the page. The data in the map frames is not included,

just the path (just like an mxd).

To save a layout as a layout file, from the catalog view or pane, right click the layout and select

Save As Layout File.

Home

Insert Analysis View Imagery Share XTools AGP
= New Layout ~ Toolbox G5 Add - e
(5] Import M % Add Folder | G New ~
e 5 Import Map & older ,pf ew o
Map -~ ¥3 Connections - Task - 2 Import ftem -
Project Styles Favorites
Contents ~ 1 X :| ops_2018_ProDemoFire COABC123_pro Layout ops_ansiC_|
= Project @ (@D » Project » Layouts
& Maps Name Type Date
&= Toolboxes Layout Layout
! Databases 2| ops_ansiC_land 2018 ProDemoFire COABC123 pro Layout
B Layouts | ZLEI QOpen
o Shi= . @ Save As Layout FiI[\'5
&l Servers Copy
Tasks =2 Export to File..,
! Folders # Rename
Save it to the projects folder in the incident file structure and name it following GSTOP
standards.
Save Layout As PAGX File *
{_“f_:':D“ 2018_ProDemoFfire W projects » v EI | Search Home g ‘
Organize ¥ New ltem ~ T
J| = Project Mame Type Date
& Folders backups Folder {25/
4 [{3 Computer
Desktop
Documents
Downloads
{:I"\_
- | ]
Mame DemaFire_COABC'IB_praIpagx‘ Layout Files (PAGX) .|
e |
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Import Layout from Template

Pro supports both the new .pagx layout
files as well as ArcMap .mxd files for
import.

To import a layout, from the Insert tab on

Analysis

i Add -

View

. . Map = ANSI - Portrait
the ribbon, click New Layout and select
Import a Layout File from the bottom of the 0 0
dropdown. Con
B =
Import X
(€5 (®)|[El » Project » Folders » 2018_ProDemoFire » projects » ~ | 0| | search project p -]
Organize ¥ MNew ltem v t =
A| = Project |‘ Name Type Date
B Foldérs il backups Folder 4/25/.
4 (@A Portal I% iap_11x17_land_2017_incidentname_unitiDlocalincide  Map Document 4/30/
C,S\ My Content ops_ansiC_land” 2018 _ProDemoFire COABC123 prop Layout TR
@b Groups
5 All Portal

B Living Atlas
4 [{3 Computer

v 4

3

Name | iap_11x17_land_2017_i nciden‘tname_unitIDIocaiincidentID,r| | Default

-

[_ox ]

Cancel |

9" 5 12"

150 - Portrait

A5
148 mm = 210 mm

150 - Landscape

O

Import a layout file...

Custarn page size...

Select page from printer...

12" % 18"

O

Ad

210 mm = 297 mm

s

Imagery

Tabla
11" =

Tabld
11" =

Architeci
18" =

Architeci
18" =

A3
297 mm =
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